v3.0.0.1: Bug in Logical Sort+Sub Dir Sorting

Post any Bulk Rename Utility support requirements here. Open to all registered users.

v3.0.0.1: Bug in Logical Sort+Sub Dir Sorting

Postby Emerkamp » Fri Aug 05, 2016 12:30 pm

Hello:
I'm seeing a few problems while using logical sort and the collum Sub. Dir

Setting are:
Display>> Sort>> Logical Sorting is ticked
(10) Suffix and pad by x4. Folder stop is ticked
(2) Remove
(12) Filter [Folders] and [Subfolders]

Now Have 1 Parent folder with 5 or more Subfolders .
Add 5 or more subfolders inside each of these folders
Have 20 or more files inside each bottom level subfolder

filename scheme is like this inside all folders:
name - (1)
name - (2)
name - (3)
ect
ect
name - (10)
name - (11) to (20)

Open the the parent folder
Sort with the Sub Dir Colum and switch between each of the 1st level subfolders that contain 5 folders+files with the treeview
1 of 2 things usually happen.

1. All suffix numbers under new name will be all [newname - 0001 or some other random number. Until you Tick and un-Tick the folder option in step (10)
or
2. The logical sort order is ignored and ordered as (1), (10) instead of (1), (2). Until you hit the Name Collum and back to the Sub Dir Collum.

This doesn't seem to happen 100%, but I would say about 90%. So everytime you switch through folders inside the tree you have to keep a close eye
on your new naming scheme to make sure its good. It also sometimes causes a Same name conflict that even the avoid option can't handle.

Thanx for the software and any help..
Emerkamp
 
Posts: 88
Joined: Sat Aug 23, 2014 2:35 pm

Re: v3.0.0.1: Bug in Logical Sort+Sub Dir Sorting

Postby FileMangler » Sun Aug 07, 2016 11:32 pm

This may be related, so I put It here instead of opening a new thread.

Task: Auto-number with suffix _001 _002 etc
I do NOT want to auto-number subfolders, only files.

My .bru contains 2 sections:
- Numbering (10) - where I add the suffix _001 etc
- Filters (12) - where I disable "Folders"

When I tweak my settings, then REVERT to .bru, the subfolder won't disappear, it gets included and messes up my numbering scheme. Loading it via File > Open however, works nicely.

When I Ctrl-deselect the subfolder manually in the list, it still messes up my numbering scheme (shifting it down the line)

When I enable the checkbox "Folder" in section "Numbering (10)", then click it again to disable it immediately, BRU finally gets it and does what I want, excluding the subfolder from my numbering scheme.
FileMangler
 
Posts: 9
Joined: Sun Aug 07, 2016 11:19 pm


Return to BRU Support