BRU 64-bit has stopped working in WinX during extract EXIF

Post any Bulk Rename Utility support requirements here. Open to all registered users.

BRU 64-bit has stopped working in WinX during extract EXIF

Postby Koshka » Sun Feb 05, 2017 2:28 am

Fresh install of BRU 3.0.0.1 on my main WinX Home version machine (Dell Inspiron 15 5000 series 16GB RAM Corei7). Went to extract EXIF data from collection of JPEG files. The data was extracted by BRU and was displayed in the BRU file list pane but I received a fatal error message "Bulk Rename Utility 64-bit has stopped working" when I refreshed (F5). I had to then close BRU to retry. The folder I was working on has about 1224 JPEGs - a collection of photo scans and JPEGs taken by several different cameras and smartphones - occupying approx 2GB of storage. EXIF extraction works without error on other folders containing fewer JPEG files. The error recurs on EXIF extraction from a different folder (this time on a USB drive) containing the same 1224 JPEGs plus an additional 21 JPEG files. I repeated this process using my wife's WinX Home version machine (Sony VAIO 8GB RAM Corei5) and the same fatal error occurred during EXIF data extract on the 1245 JPEG files on the USB drive. Please advise on next steps.
Koshka
 
Posts: 5
Joined: Sun Feb 05, 2017 1:04 am

Re: BRU 64-bit has stopped working in WinX during extract EXIF

Postby Koshka » Sun Feb 05, 2017 3:06 am

Addendum: the problem did NOT occur when using BRU 64-bit on a different folder containing 1937 JPEG, PNG and QuickTime files in 8.37GB of storage.
Koshka
 
Posts: 5
Joined: Sun Feb 05, 2017 1:04 am

Re: BRU 64-bit has stopped working in WinX during extract EXIF

Postby Koshka » Sun Feb 05, 2017 4:20 am

Addendum #2: the problem was caused by one 1.10MB JPEG file. When I looked at the file properties it turns out the file date is 1/1/4501. That out of whack date probably caused the utility to crash.
Koshka
 
Posts: 5
Joined: Sun Feb 05, 2017 1:04 am

Re: BRU 64-bit has stopped working in WinX during extract EXIF

Postby Koshka » Sun Feb 05, 2017 4:28 am

Addendum #3: Now I'm stuck. Although I used BRU to change the timestamps on the file causing the BRU crash it is still showing file date 1/1/4501 in File Explorer and it still causes a fatal error in BRU when I include Date Taken and refresh (F5) the file list. Any help would be appreciated.
Koshka
 
Posts: 5
Joined: Sun Feb 05, 2017 1:04 am

Re: BRU 64-bit has stopped working in WinX during extract EXIF

Postby Emerkamp » Sun Feb 05, 2017 6:49 am

Hi:
You'll probably have better luck making a new file somehow. Crop then save or something.
It's hard, not knowing what date is wrong. if it's exif, you can use a photo app like exif tool or Geo-Setter to fix. If it's a file property, then a file commander app might help.
Emerkamp
 
Posts: 88
Joined: Sat Aug 23, 2014 2:35 pm

Re: BRU 64-bit has stopped working in WinX during extract EXIF

Postby randy_randy » Tue Mar 07, 2017 6:30 pm

Yes, the date is exactly the issue. I'm not sure how I end up with files with that date, however the easiest workaround I have found is to show that folder of files in Explorer, show the column for Date Taken and then sort by that column. Right click on the files that have that date and on the Details tab either change the date taken to something current, or Remove Properties to clean all EXIF field info. Then BRU handles the file no problem.

The latest version, as of today, v3.0.0.1 under Windows 10 Pro also has this issue. Hopefully a future update allows for these weirdly dated files. It is still a great utility.

-Randy-
randy_randy
 
Posts: 1
Joined: Tue Mar 07, 2017 6:24 pm

Re: BRU 64-bit has stopped working in WinX during extract EXIF

Postby therube » Wed Mar 08, 2017 4:46 am

Is/was 1/1/4501 also the date recorded in the files EXIF data?
Simply modifying a files modified date to 1/1/4501 didn't seem to be an issue in BRU.
(I didn't try with created/accessed.)

(Seemingly 1/1/4501 the representation of an "empty" date value [in MS Outlook].)


PS: What is "WinX" ?
therube
 
Posts: 316
Joined: Mon Jan 18, 2016 6:23 pm

Re: BRU 64-bit has stopped working in WinX during extract EXIF

Postby therube » Wed Aug 16, 2017 6:09 pm

At the time, I might not have followed correctly. Anyhow...

> Simply modifying a files modified date to 1/1/4501

Seems when I created the file, I noted in the filename, 1-1-4501, but I actually created the file date (modified) as 1-1-4051 (4051 vs 4501).

> PS: What is "WinX" ?

Duh, Windows 10.


Looking at this again, now, XP, BRU 3.0.0.1...
With a file, date modified, as either 1-1-4051 or 1-1-4501...

8:Auto Date
Prefix
Modified Current

returns a "The parameter is incorrect" dialog box.
No crash though.
(And I have no way to modify a pictures exif date to test that end.
BRU displays the file date [modified] as it is, 01/01/4501, but will not allow the 8:Auto Date to change the file name based upon that date [modified])
therube
 
Posts: 316
Joined: Mon Jan 18, 2016 6:23 pm

Re: BRU 64-bit has stopped working in WinX during extract EXIF

Postby therube » Wed Aug 16, 2017 6:25 pm

OK, you can just use a hex editor & go in & change the date stored in the .jpg.

OK, confirmed - when you try to open a directory with an "affected" file.

If you simply drag the particular file into BRU, BRU simply say "no good", but does not crash.

But if you try to open the directory containing the file - from with in BRU, using the "Tree picker", then BRU does actually crash.


And it does depend on the file extension.
If you rename the file, name.jpg to name.jpg.XXX, then BRU does not attempt to read any EXIF data from the file, so no crash occurs.
therube
 
Posts: 316
Joined: Mon Jan 18, 2016 6:23 pm

Re: BRU 64-bit has stopped working in WinX during extract EXIF

Postby therube » Fri Sep 15, 2017 7:01 pm

I'll also note that when this happens, BRU maintains a lock on said file until BRU is closed.
therube
 
Posts: 316
Joined: Mon Jan 18, 2016 6:23 pm


Return to BRU Support


cron