encountered improper argument

Post any Bulk Rename Utility support requirements here. Open to all registered users.

encountered improper argument

Postby ssamorez » Sat Nov 14, 2009 11:56 pm

I am able to install w/win7pro...had to manually add to SEND TO..., but when BRU loads, I get this error: encountered improper argument. When this error message occurs BRU will not list individual files in the work window! If I run BRU as an executable, it works OK.
ssamorez
 
Posts: 2
Joined: Sat Nov 14, 2009 11:47 pm

Re: encountered improper argument

Postby RogerO » Sat Oct 03, 2020 3:29 am

I would like to add my 2 cents to this error condition.

A week or two ago when attempting to execute the previous version of BRU (meaning what I had on my system = 3.0.0.1), and with a clean and first time display of the main window - I attempted to quit BRU immediately by various methods and they all gave me a small window showing the words "Encountered improper argument". This was constant.

I looked for a newer version and gladly found 3.4.0.0. So I downloaded, installed and executed it and it exited fine using the same various methods. Over and over again. I thought the problem was gone in this new version.

So now after a couple of days and executing it several time, I have just experienced this problem again. I wasn't going to bring it up now but it has still got a problem somewhere.

But the problem is slightly different than with ver 3.0.0.1. This time using 3.4.1.0 the error window popped up the first time the main window displayed. If I attempted to exit the result would be another message window that showed a larger amount of exit, but it boiled down to "The program is expecting input from me" and so I could not exit. I finally noticed a button saying something like "To exit - Press OK" so I did and it went away.

I executed this program under both Win7 and Win8 - Win8 on a Laptop did not give this problem trying to exit - Win7 on a Desktop is showing this problem on exit, but not every time. So I guess we can put it on the back burner until I can back this up with more solid results. I will come back here if there is newer information.
RogerO
 
Posts: 4
Joined: Wed Sep 30, 2020 10:04 am

Re: encountered improper argument

Postby Bacchus66 » Sat Oct 17, 2020 10:55 pm

I just started countering this issue. This started happening just a couple of weeks ago, either just before or just after I upgraded to 3.4.1 (directly from 3.3.2.1) on the 6th or 7th of October. two weeks ago. It's been a couple of weeks, so I'm not 100% sure of the sequence. Either I started having the issue and checked for an update, or I did the update and started having the issue. I assumed it was a session thing and really didn't pay much attention to details since other then the annoying extra step of re-selecting the starting point it doesn't seem to affect actual operation. Still, it's annoying. Especially the loss of the ability to pre-select certain files.

For me it is specific to launching Bulk Rename Utility via the Windows Explorer extension. Whether I am doing that with a folder selected, or with one or more individual files selected, I get the same "Encountered improper argument" dialog on startup. I tested, and If I start BRU from it's shortcut (which I normally would never do), the application launches fine. It's only when i launch via the explore extension (ie right click .. bulk rename here) that the issue occurs.

I have done a LOT of bulk renames over the last several months, both by selecting a folder as a staring point, and by selecting a specific set of files within a folder, and would have noticed it long before if it wasn't a very new issue. Prior to a couple of weeks ago this always worked fine, and now it doesn't.

As noted, not critical, just annoying do to the slight loss of functionality and additional overhead involved in ignoring the error and selecting the dir to search again.

Thanks in advance for any info.
Peter S
Bacchus66
 
Posts: 4
Joined: Sat Jun 27, 2020 1:02 am

Re: encountered improper argument

Postby Admin » Sun Oct 18, 2020 5:41 am

Thanks for the report, does this happen on a specific set of files or a specific folder? Is it reproducible, i.e. if it happens once and you reselect the same files/folder does it happen again and every time? thanks
Admin
Site Admin
 
Posts: 1902
Joined: Tue Mar 08, 2005 8:39 pm


Return to BRU Support