Change File Timestamps not working - hours off-by-one error

Post any Bulk Rename Utility support requirements here. Open to all registered users.

Change File Timestamps not working - hours off-by-one error

Postby ironick » Tue Oct 17, 2017 7:17 pm

I use BRU from time to time and really appreciate what a great utility it is. I'm suddenly having a small problem with it. I'm in the process of renaming and changing timestamps on jpg images. I have 104 directories, each with about 25 images. Each directory represents a roll of film.

In the Change File Timestamps dialog box, I've been using the Fixed option to change the Date Created and Date Modified. I've been using the following time with a variety of dates (different dates for the images in different folders): 11:17:19 AM. It's been working fine for the past several hours (I've processed several dozen directories worth of images).

Suddenly, in the directory I'm working in, after I hit the OK button on the Change File Timestamps dialog box, the highlighted files in the directory show the correct date I'm changing to, but the time shows 10:17:19 AM, ie the hour is off by one! I've stopped the utility and started it again but it is still happening. I searched the forum and found that someone had reported a similar problem many years ago (2006?), but it sounded like it was in the other direction, ie it added an hour. I've tried it in a couple other directories as well and the same problem occurs.

For now, the simple workaround is to use the time 12:17:19 AM in the dialog box, which causes the timestamp to be the desired time of 11:17:19 AM. I'm using BRU version 3.0.0.1 on an up to date version of Windows 10 64bit.

Thanks,

-- Nick
ironick
 
Posts: 2
Joined: Tue Oct 17, 2017 6:59 pm

Re: Change File Timestamps not working - hours off-by-one error

Postby therube » Tue Oct 17, 2017 9:02 pm

Do you have DST set to automatically change?
Did your work session span noon or midnight?
therube
 
Posts: 419
Joined: Mon Jan 18, 2016 6:23 pm

Re: Change File Timestamps not working - hours off-by-one error

Postby ironick » Wed Oct 18, 2017 3:41 pm

It's definitely not a DST issue. The renaming was in the middle of the day, nowhere close to midnight. Also, it's worse than I thought. Now it decrements the hour on the timestamp intermittently, ie in one rename of a batch of files in one of my 104 directories, the hour will decrement, but with the next batch it won't!?!

I'm testing a variety of scenarios to try to detect a consistent pattern of when it decrements and when it doesn't, but it's been very difficult due to the ever changing behavior. For example, in a few of the renames the DAY actually decremented instead of the hour!?! Another example is that for a couple of renames, the AM was switched to PM, but the hour was not decremented!?! In my 40+ years of working with computers, I can't remember seeing such random behavior in an otherwise working application.

One thing that seems to help is that I uncheck the Change File Timestamps checkbox before each rename. That seems to prevent the strange behavior 8 out of 10 times or so. I'm mystified.

Luckily, I only have about a dozen directories left to rename today! :)

-- Nick
ironick
 
Posts: 2
Joined: Tue Oct 17, 2017 6:59 pm


Return to BRU Support